Web lists-archives.com

Re: After installing nc (netcat), nc.exe is not found




I have these versions, and nc is here happy and playful.

It is possible you attempted an upgrade while cygwin programs were running? Cygwin services also count. This is due a limitation on windows which locks files when they are in use, so cygwin updates can't replace the files and end up failing.

You may ensure everything is closed and services stopped, re-run setup-x86_64.exe, selecting the 'nc' package and switching it to "Reinstall". Then let the setup do its things.

If the setup is hanging, or have hung up and you had to force-close it the last install attempt you did, this is a strong sign that not just nc, but several other packages that have been attempted to upgrade may be compromised. To ensure that is not the case, a good

cygcheck -c

should help.

The package nc-1.10-4.tar.bz2 has 'usr/bin/nc.exe', which is the file you claim missing.

Hope this helps! :)


On 7/11/2018 2:10 PM, Mark Hansen wrote:
I've just updated to the latest Cygwin 64-bit installation on my Windows 7 PC. Included in this update was the package for nc (nc: A simple but powerful network tool) version 1.107-4

After downloading and installing, which all seemed to go fine, the man page for nc is there,
but nc.exe is not.

I included the following (netcat-related) packages:
- nc, 1.107-4
- nc6, 1.0-1
- nc6-debuginfo, 1.0-1

Is there something special I need to do to get nc.exe installed?

Thanks,


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple