Web lists-archives.com

Re: Cygwin x86 on Windows 10 ARM64




On 2018-07-10 03:51, David Allsopp wrote:
> I've been trying out the x86 emulation in Microsoft's ARM64 version of
> Windows 10 1803.
> 
> I had two issues with Cygwin x86. The first, which is simple, is that
> Windows doesn't by default create C:\Windows\SysWOW64\drivers\etc which
> causes /etc/postinstall/base-files-mketc.sh to exit with an error all the
> time. I wonder if there's a possible workaround to make that less intrusive?
> The error message implies that it may have computed the wrong directory,
> which it hasn't - it's just that the directory doesn't exist.

Do C:\Windows\{System32,SysNative,Sys*}\drivers\etc exist under the emulator?
What does "cygpath -SU" show?

> The other is that all Cygwin binaries are emitting the "Could not compute
> FAST_CWD pointer" warning.

It is just a warning and everything should run normally: what would normally be
an ntdll entry point on x86 is probably a thunk or trampoline to
arm64(ISA)/aarch64(mode)/armv8(design) code.

> Everything's up-to-date and I also tried it with the 2018-06-29 cygwin1.dll
> snapshot.
> 
> Very happy to test things and poke around, I'd just need some pointers, if
> you'll excuse the pun.

Someone with deep knowledge of W10 will have to advise on that.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple