Web lists-archives.com

Re: Entry point not found issues with cygwin DLLs




On 2018-07-02 14:36, Heavenly Avenger wrote:
> On 7/2/2018 5:02 PM, Brian Inglis wrote:
>> On 2018-07-02 13:35, Ken Brown wrote:
>>> On 7/2/2018 3:08 PM, Heavenly Avenger wrote:
>>>> I'm having hard times with cygwin here, random libraries stop working once I
>>>> update or install new ones.
>>> This can happen if you update a package without updating its dependencies.  For
>>> example, the dependency might have introduced a new API.
>>>> If I run ssh with 'strace' ('strace ssh'), it pops up a windows dialog saying:
>>>> 'the procedure entry point __memcpy_chk could not be located
>>> It is in cygwin1.dll as of cygwin-2.10; see
>>> https://cygwin.com/cygwin-ug-net/ov-new.html.
>>>> cygwin's dll is: cygwin1.dll file version: 2008.0.0.0, version: 2.8.0.
>>> You need to update the cygwin package.  For best results, you should update all
>>> of your installed packages to their current versions.  (If you're running setup
>>> with the --packages option to update or install certain packages, then it's a
>>> good idea to also use the --upgrade-also option.)
>> Also ensure no processes using Cygwin are running, before starting a freshly
>> downloaded https://cygwin.com/setup-x86_64.exe, and wait until setup has
>> finished all processing and exited, before using any Cygwin programs:
>> otherwise autorebase and other postprocessing may not work properly.
> Thanks! I'm almost 100% sure this was the cause, I remember the cygsetup getting
> stuck during installation some times, but at the time no immediate issue was
> noticed after installation.
> For example, ssh client was working until this weekend when I upgraded it, and I
> recently had rolled perl back in order to fix it -- which broke once again. :)
> so the installation was tainted for some time already. :(
> Hopefully with the "cygcheck overhaul" it will become stable.

Running cygcheck with appropriate options just points out the problems, that you
can then fix by doing reinstalls or upgrades with setup.

If anything appears to go wrong during setup, just be patient and let it finish.
If anything seems wrong while testing, just exit all Cygwin processes, and rerun
setup again.

On my last setup run to upgrade packages, I forgot I had a Windows task
scheduled, which runs a Cygwin script, that creates dozens of background Cygwin
processes, each of which runs dozens of Cygwin commands and other scripts. I
just let all processes in that task, and setup, finish; then immediately reran
setup, accepting all the defaults, and allowed that to complete, after which
Cygwin/X with a mintty terminal started normally.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple