Web lists-archives.com

Re: sshd issues on Windows 10 version 1803




Upon upgrading another 1709 node (with working Cygwin sshd), the 1803
update clobbered the sshd service registry tree. The older Cygwin sshd key
was deleted and a new sshd service got created pointing to
%SystemRoot%\System32\OpenSSH\sshd.exe.
This is different from what I observed on the 1st node that I upgraded a
few weeks ago (wherein the Cygwin sshd registry tree was left intact). I
deleted the sshd service, rerun ssh-host-config, and am back to random
failed auto-restarts of sshd.

I think there is a myriad of issues here, the least of which is MS
hijacking the "sshd" service name. As a minimum, the default 'service_name'
in ssh-host-config should be changed to not conflict with "sshd". Maybe
ssh-host-config should also consider deleting any pre-existing "sshd"
service and then recreate a new one. The FAQ may require some mention as
well.

I got another hit of this conflict on the web at
https://gist.github.com/roxlu/5038729  (last few comments).

Thanks.

On Tue, Jun 26, 2018 at 1:16 AM, Corinna Vinschen <corinna-cygwin@xxxxxxxxxx
> wrote:

> On Jun 25 11:59, Hiya Z wrote:
> > >Btw., I can't reproduce this problem.  Cygwin's sshd service always
> > >starts for me at boottime as expected.
> >
> > >Did you check if the log file in /var/log contains any more info?
> >
> > I see nothing in /var/log/sshd.log. Windows event log shows following
> > errors:
> >
> > --
> > Error      6/20/2018 3:45:19 PM   Service Control Manager
> > 7009      None
> > A timeout was reached (30000 milliseconds) while waiting for the sshd
> > service to connect.
> >
> > Error      6/20/2018 3:45:19 PM   Service Control Manager
> > 7000      None
> > The sshd service failed to start due to the following error:
> > The service did not respond to the start or control request in a timely
> > fashion.
> > --
> >
> > Another odd behavior that I observe is that after a reboot, starting a
> > Cygwin64 terminal (first time) takes a long time. Launching subsequent
> > mintty terminals is quick as it should be. Could it be that sshd startup
> > upon reboot is hitting the same delay as the 1st mintty?
> >
> > Will try removing %SystemRoot%\System32\OpenSSH from the PATH to see if
> it
> > improves things.
>
> I didn't remove it and it works fine for me.  The OpenSSH path is
> pretty late in $PATH and should not affect starting with cygrunsrv
> because it prepends /bin to $PATH before running the service...
> unless you used the -e option to cygrunsrv to infuse your own $PATH.
>
>
> Corinna
>
> --
> Corinna Vinschen                  Please, send mails regarding Cygwin to
> Cygwin Maintainer                 cygwin AT cygwin DOT com
> Red Hat
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple