Web lists-archives.com

Re: [bug: csih] Setting privileged rights to cyg_server fails on Windows 7.




Hi Corinna,

On Fri, 15 Jun 2018 15:34:15 +0200
Corinna Vinschen wrote:
> > In this case, LOGONSERVER is NOT set in my environment.
> > Are you sure of the above result?
> Yes, I had all results before me when I wrote the mail.  This was on W10
> Enterprise.

My environments are Windows 7 Professional (32bit) and Windows 10 Pro
(64bit). In both cases, LOGONSERVER is not set. It is strange that
the results are different even in a similar environment.

> > *** ERROR: winProductName: C:/cygwin/lib/csih/winProductName.exe: error while loading shared libraries: libssp-0.dll: cannot open shared object file: No such file or directory
> Apparently only the native tools winProductName and getAccountName
> are affected by this build problem.  It seems that with newer versions
> of gcc we need to specify --static during the link stage, otherwise
> we pull in unwanted shared object dependencies.
> 
> I'm going to push a new version in a bit.

I have confirmed this is fixed in csih-0.9.11-1. Thank you.

By the way, what do you think of the patch I proposed yesterday?

On Fri, 15 Jun 2018 19:56:35 +0900
Takashi Yano wrote:
> To resolve this problem, I would like to propose a patch attached.
> I tested the patch for above 8 scenarios, and succeeded for all.
> Could you please have a look?

I will appreciate any comments.

-- 
Takashi Yano <takashi.yano@xxxxxxxxxxx>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple