Web lists-archives.com

Re: [bug: csih] Setting privileged rights to cyg_server fails on Windows 7.




On Jun 14 06:22, Takashi Yano wrote:
> Hi Corinna,
> 
> On Wed, 13 Jun 2018 20:14:07 +0200
> Corinna Vinschen wrote:
> > There's something fishy in your environment.  The variable LOGONSERVER
> > is always set in Windows NT, at least since NT4.  For standalone
> > machines LOGONSERVER is set to "\\<machinename>".  You should really
> > try to find out why LOGONSERVER isn't set for you.
> 
> With your advice, I have found the cause. I usually logon as a user
> who does not have administrator rights for security reason. This user
> belong to only "Users" group. When I need administrator rights,
> I use "Run as administrator" menu to switch to another user who
> has administrator rights. In this case, LOGONSERVER is not set.
> 
> If I logoff from the first user account and logon as the second user,
> LOGONSERVER is set.
> 
> Moreover, the behaviour above seems to be true not only on Windows 7,
> but also on Windows 10.
> 
> I have confirmed that iu-config successfully finishes without the
> patch I proposed, if I logon as an administrative user instead of
> using "Run as administrator".
> 
> Thank you very much.

Thank you, too.  I pushed the patch and will release a new csih package
soon.


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: signature.asc
Description: PGP signature