Web lists-archives.com

Error using git-svn (module List::Util: No such process at /usr/share/perl5/5.26/XSLoader.pm line 96)




Hi all,

I'm getting the following error using git-svn (I think the only change I
made was that I updated subversion)

➤ git svn rebase
Can't load
'/usr/lib/perl5/vendor_perl/5.26/i686-cygwin-threads-64int/auto/List/Util/Util.dll'
for module List::Util: No such process at /usr/share/perl5/5.26/XSLoader.pm
line 96.
 at /usr/lib/perl5/vendor_perl/5.26/i686-cygwin-threads-64int/List/Util.pm
line 23.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.26/i686-cygwin-threads-64int/Scalar/Util.pm
line 23.
Compilation failed in require at /usr/share/perl5/vendor_perl/5.26/Error.pm
line 48.
BEGIN failed--compilation aborted at
/usr/share/perl5/vendor_perl/5.26/Error.pm line 48.
Compilation failed in require at /usr/share/perl5/vendor_perl/5.26/Git.pm
line 104.
BEGIN failed--compilation aborted at
/usr/share/perl5/vendor_perl/5.26/Git.pm line 104.
Compilation failed in require at /usr/share/perl5/Git/SVN.pm line 24.
BEGIN failed--compilation aborted at /usr/share/perl5/Git/SVN.pm line 24.
Compilation failed in require at /usr/libexec/git-core/git-svn line 21.
BEGIN failed--compilation aborted at /usr/libexec/git-core/git-svn line 21.

--
versions are:
svn, version 1.9.7 (r1800392)
git version 2.16.2
perl (v5.26.1)


Any idea how to make git-svn work again?


Thanks all
Iván García

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple