Web lists-archives.com

Circular dependency with mingw64-x86_64-runtime




Here are the requirements for "gcc-core":

 binutils, cygwin-devel, libatomic1, libgomp1, libisl15, libmpc3, libquadmath0,
 libssp0, w32api-headers, w32api-runtime, windows-default-manifest

and for "w32api-runtime":

 w32api-headers

Here are the requirements for "mingw64-x86_64-gcc-core":

 libisl13, libmpc3, mingw64-x86_64-binutils, mingw64-x86_64-headers,
 mingw64-x86_64-runtime, mingw64-x86_64-windows-default-manifest,
 mingw64-x86_64-winpthreads

and for "mingw64-x86_64-runtime":

 libisl13, libmpc3, mingw64-x86_64-binutils, mingw64-x86_64-gcc-core,
 mingw64-x86_64-headers, mingw64-x86_64-windows-default-manifest,
 mingw64-x86_64-winpthreads

so "mingw64-x86_64-gcc-core" and "mingw64-x86_64-runtime" require each other. I
think that the requirements for "mingw64-x86_64-runtime" should be adjusted on
so that they are similar to "w32api-runtime".


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple