Web lists-archives.com

Re: Issue displaying characters on interactive commands




On 2018-04-20 05:24, Peter Dilov via cygwin wrote:
> If i run 'aptitude' command when i try to exit the command i get this strange
> exit window like in the screenshot:
> https://i.imgur.com/oxGntcr.png
> I also have noticed this problem with other interactive commands like 'ncdu'. I
> am using Cygwin on Windows 7 x64.

As these are character terminal windows, you could just have copied (using mouse
drag-select then primary [normally left] mouse button) and pasted the *relevant*
displayed characters into your email, instead of snapping a full screen shot
image of a remote server and linking to it: you are not alone in this, as many
articles and ebooks are illustrated with full screen shots showing a couple of
lines of a tiny font lost in a mass of dark screen background colour.

You fail to mention this is using ssh to another system, where your issue is
that you are seeing other characters interspersed with box drawing characters,
probably because your remote system is using UTF-8, and your local Cygwin system
is using a (localized or default) Windows encoding.

Please ensure that your LANG/LC_ALL charset encoding settings are the same on
both systems e.g. "export LANG=en_US.UTF-8" (check by running "locale" on both
systems to see these settings), and respected by the remote system and package
you are using, or change your local setting to match your remote setting.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple