Web lists-archives.com

Re: msmtp depends on Gnome!?




On 28/03/2018 22:50, Stephen Paul Carrier wrote:
Dear cygwin people,

msmtp is billed as a light-weight SMTP client and I would like to use
it with cron instead of ssmtp.

What's not light-weight is its dependency on libgnome-keyring0 which
has more dependencies that eventually bring in Gnome.  This is for a
headless workstation.

Is it possible to remove or replace this dependency so that msmtp can
be installed without enlarging the size of the install by such a factor?

Thanks!

Thanks for pointing this out.

These dependencies just seem to be out of date.

According to [1], msmtp hasn't required gnome-keyring since 1.6.0. It's capable of using libsecret instead, but our package doesn't seem to be built with support for that.

Additionally, 1.6.6-1 is built against libgnutls30, but libgnutls28 is listed as dependency.

I adjusted these dependencies on sourceware.

[1] http://msmtp.sourceforge.net/news.html

Jari,

Please check your local copy and/or double-check these going forwards.

Also, msmtp 1.6.6-1 doesn't seem to have been built for x86, at all.

Thanks.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple