Web lists-archives.com

Re: texlive-collection-basic requires Perl to be removed




On 3/22/2018 10:10 PM, Steven Penny wrote:
This package contains this file:

    /etc/preremove/texlive-collection-basic.sh

which in turn calls:

    /usr/libexec/update_tlpdb

which is a Perl script. I understand that "texlive-collection-basic" requires "perl_base", but if a user removed Perl first then uninstallation of texlive
would fail. Perhaps "update_tlpdb" could be rewritten as a shell script.

Failure of a preremove script doesn't cause uninstallation to fail.

In any case, update_tlpdb is the tip of the iceberg. The preremove script also calls (indirectly) the Perl scripts /usr/share/texmf-dist/scripts/texlive/updmap.pl and /usr/share/texmf-dist/scripts/texlive/fmtutil.pl.

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple