Web lists-archives.com

Re: cygcheck-dep and _obsolete packages




On Wed, 28 Feb 2018 22:57:05 +0100
Marco Atzeri <...> wrote:

> Hi Mikhail,
> 
> as latest setup skips the installation of _obsolete packages
> can you adjust the behaviour of cygcheck-dep to ignore
> the false warning ?
> 
> /usr/bin/cygcheck-dep: WARNING: broken dependencies:
> /usr/bin/cygcheck-dep:   installed package 'cygwin/xorg-server-devel'
> /usr/bin/cygcheck-dep:   depends on the following required packages that are
> /usr/bin/cygcheck-dep:   not installed; these dependencies will be discarded
> /usr/bin/cygcheck-dep: ( fontsproto inputproto kbproto presentproto 
> randrproto renderproto resourceproto scrnsaverproto xextproto 
> xf86bigfontproto xineramaproto xproto )
> 

Hello, Marco
I will change the script (along with dropping cygwinports support).
At present cygcheck-dep prints out exactly what setup.ini claims about
what the package is requiring, and as per I have understood, now setup.exe
does not install requisites from the _obsolete category, using instead
the packages by which they are obsoleted.

-- 


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple