Web lists-archives.com

setup -g ???




Should we still be using the -g (--upgrade-also) flag on setup?

---------- Forwarded message ----------
From: Jon Turney
Date: Fri, 3 Nov 2017 15:26:27 +0000
Subject: Re: Problem running the latest python2-2.7.14-1 under AppVeyor
To: The Cygwin Mailing List <cygwin@xxxxxxxxxx>

On 03/11/2017 14:45, Vadim Zeitlin wrote:
> Our build has started on AppVeyor, a continuous integration provider,
> started failing since a couple of days as a makefile command running a
> Python script started failing with exit code 127 without any more
> information. This is a strange situation as I can't reproduce the problem
> locally, but something definitely seems to be wrong with this package on
> the AppVeyor machine as Python just doesn't seem to be executable, e.g. the
> output of these commands in our batch file driving the build:

Perhaps you need to provide the -g (--upgrade-also) flag to cygwin's setup.

Due to setup terribleness, without this flag, it will install the
requested packages, and any missing dependencies of them, but not
upgrade any of the dependencies which are already installed to the
current (and perhaps needed) version...

See also [1].

[1] https://sourceware.org/ml/cygwin/2017-03/msg00365.html


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple