Web lists-archives.com

(solved) Re: Mismatch between the program and library build versions detected. for wxWidgets





I found the workaround 

https://github.com/eranif/codelite/issues/825

Add 
CPPFLAGS=-D__GXX_ABI_VERSION=\"1009\" 

to configure script erase warining.

Tatsuro

****** previous post (edited typo ) ***************
I have met following warning gnuplot build with wxt terminal 
gnuplot> pl x 

12:43:09: Warning: Mismatch between the program and library build versions
detected. 
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx
containers,compatible with 2.8), 
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx
containers,compatible with 2.8). 

Perhpas re-build wxWidgets using current build tools that I use for gnuplot
build will get out this warining. 
Is there any workaround to avoid the warning. 

Reference 
$ gcc --version 
gcc (GCC) 6.4.0 
Copyright (C) 2017 Free Software Foundation, Inc. 
This is free software; see the source for copying conditions.  There is NO 
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 
Tatsuro  



--
Sent from: http://cygwin.1069669.n5.nabble.com/Cygwin-list-f3.html

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple