Web lists-archives.com

Re: Eclipse running on debian with remote display to cygwin X11 starts all squashed to a point

On 07/03/2018 17:40, Steinar Bang wrote:
Jon Turney :

This seems like a problem with the integrated WM not doing what is
expected, Java programs do seem to be problematic in this regard.  So,
you can probably work around this by running the Cygwin X server in
windowed, rather than multiwindow mode.

I've thought about trying it but it's not really the behaviour I want.

It might also be worth trying adding the '-extension RANDR' option to the X server, to disable RANDR.

I tried to reproduce this, but eclipse worked ok for me.

Can you tell me the versions of Xwin, debian and eclipse you are using?

"uname -r" in cygwin reports:

sb@mccoy:~$ cygcheck -c | grep xorg
xorg-server               1.19.6-1                OK
xorg-server-common        1.19.6-1                OK
xorg-x11-fonts-dpi75      7.5-3                   OK
xorg-x11-fonts-misc       7.5-3                   OK

The debian version is 9.3.

The eclipse version is eclipse oxygen, installed with the eclipse
installer from


Well, with those details, I was able to reproduce some weird behaviour (not working menus, oddly placed windows), although not exactly what you see.

You didn't mention if any warnings are written by eclipse to the terminal?

That seems to be related to certain versions of GTK+ getting confused by the RANDR data provided by XWin and ending up believing the display is 0x0 pixels in size.

I've built a snapshot with some potential fixes. Perhaps you could try that and see if it improves things for you?


Jon Turney
Volunteer Cygwin/X X Server maintainer

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple