Web lists-archives.com

Re: Another setup v2.889 regression?

On 05/03/2018 12:50, Houder wrote:
On 2018-03-04 23:25, Jon Turney wrote:
On 04/03/2018 15:11, Houder wrote:
Because there are problems with setup v2.889, I decided to do
some testing of my own.

Thanks for reporting this.

2018/03/04 15:35:20 Augmented Transaction List:
2018/03/04 15:35:20    0 install  cscope
2018/03/04 15:35:20    1   erase  cscope             15.8b-1

 From override.hint on the "Twente" mirror:

curr: 15.8b-1

As far as understand, setup should attempt to install v15.8b1
in case v15.8.0.1-2 is installed.

Not the other way around. (currently v15.8b-1 in installed).

Yeah, this isn't working as expected. Time for a bigger hammer...

The previous version has been re-designated as 15.8a-2 (to match what
it identifies itself as with 'cscope -V').

This should make setup update to the most recent version, while still
allowing the previous version to be offered as installable...

Uhm, bigger hammer ... you mean your modification will solve the problem
for cscope, but not for f.i. the *lz4* packages?

Sigh. I thought I had fixed lz4 [1], but apparently not, it suffers from the same class of problem (briefly, replace-versions: doesn't work on versions which are also offered for installation)

These are the only other packages which I am aware of which suffer from this specific problem, and I'm not sure I want to fix those in the same way.

If you think there are other package which have this problem can you please tell me what they are...

[1] https://cygwin.com/ml/cygwin/2018-02/msg00306.html

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple