Web lists-archives.com

Re: Add emacs build with LUCID X toolkit ?

At 2018-03-05 15:03, Ken Brown was heard to say:
On 3/5/2018 8:21 AM, Alejandro Benitez wrote:
I often painstakingly work on my build of emacs and never look back, praying to never come back, but then I get some annoyances such as vfork issues I can't fix. I will go further on this in a different post.

vfork issues almost always indicate a need to do a full rebase.  See

  https://cygwin.com/faq/faq.html#faq.using.fixing-fork-failures .

Or switch from 32-bit Cygwin to 64-bit Cygwin, where such problems are
extremely rare.

Maybe add a new emacs-lucid package ?

Cygwin's emacs uses GTK+ because that's the default for an emacs build
on all unix-like platforms.  But I'll think about adding an
emacs-lucid package for the next emacs release.  It would be good to
know how much demand there is for this.  Are there other emacs-X11
users who would prefer the Lucid toolkit?

As an avid emacs user I have no desire to switch to emacs-lucid. If the extra work to provide both packages is limited, it would not hurt to have both packages though.

just my 2 cc

Markus Hoenicka
AQ score 38

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple