Web lists-archives.com

Re: Another setup v2.889 regression? additional information




On 2018-03-04 09:58, Houder wrote:
> On 2018-03-04 16:11, Houder wrote:
>> Because there are problems with setup v2.889, I decided to do
>> some testing of my own.
>> I started out with empty directories for the repo (a.k.a. the
>> Local Directory?) and the root directory ...
>> After having downloaded and installed the "required" packages,
>> I again started setup (3rd time and 4th time) to download and
>> install "cscope" (yes, one of the packages).
>> Then I started setup for the 5th time (download): it reported
>> "nothing to install".
>> When I started setup for the 6th time (install), it wanted to
>> replace cscope (v15.8b-1)  with an older version (15.8.0.1-2)
> Sorry, I should have added ...
> I always invoke setup using a shortcut, i.e. the invocation is
> always parameterized as follows:
>     E:\_cygwin64_repository-test\setup-x86_64-2889.exe \
>     -n -R e:/Cygwin64-test -l e:/_cygwin64_repository-test
> (startup-directory: e:/_cygwin64_repository-test)
>> From /var/log/setup.log:
>> 2018/03/04 15:35:04 Starting cygwin install, version 2.889
>> 2018/03/04 15:35:04 User has backup/restore rights
>> 2018/03/04 15:35:04 Current Directory: e:/_cygwin64_repository-test
>> 2018/03/04 15:35:04 Could not open service McShield for query, start
>> and stop. McAfee may not be installed, or we don't have access.
>> 2018/03/04 15:35:15 source: from local dir
>> 2018/03/04 15:35:17 root: e:\Cygwin64-test system
>> 2018/03/04 15:35:18 Selected local directory: e:/_cygwin64_repository-test
>> 2018/03/04 15:35:20 solving: 0 tasks, update: yes, use test packages: no
>> 2018/03/04 15:35:20 Augmented Transaction List:
>> 2018/03/04 15:35:20    0 install
>>    cscope          15.8.0.1-2
>> 2018/03/04 15:35:20    1   erase
>>    cscope             15.8b-1
>>
>> From override.hint on the "Twente" mirror:
>> curr: 15.8b-1
>> prev: 15.8.0.1-2
>> replace-versions: 15.8.0.1-2
>>
>> As far as understand, setup should attempt to install v15.8b1
>> in case v15.8.0.1-2 is installed.
>> Not the other way around. (currently v15.8b-1 in installed).

Version epochs need to be used to resolve version format changes.
They are now supported in most of the packaging utilities, but once they are
used in setup.ini and installed.db, all older packaging utility versions will
break.
How soon would you like that sir? ;^>
It's damned if you do, and damned if you don't: substitute your own localized
translation.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple