Web lists-archives.com

Re: setup-x86_64.exe v2.889 doesn't select additionally downloaded packages when installing from local directory

[Please don't top-post on this list.]

On 3/3/2018 10:01 PM, Robert Cohen wrote:
  Thanks for finding that. However, I am using the same "Local Package Directory" that I used
when I ran it to do the download. For example, here's where things were for all the steps:

1. Directory C:\Updates\cygwin_download, containing setup-x86_64.exe and nothing else
2. Ran setup, "Download without installing", specifying C:\Updates\cygwin_download as
      the local package directory, then selected additional packages and performed the download.

at this point, C:\Updates\cygwin_download contained setup-x86_64.exe and a
subdirectory for the mirror site. The setup.ini file was in a x64_64 subdirectory
under the mirror site subdirectory.

3. Then I ran setup again, "Install from local directory", with C:\cygwin64 as the root directory
      and C:\Updates\cygwin_download as the local package directory.

Should I have specified something differently for it to detect the additional packages that I
selected for download? I looked in setup.ini and it does list the additional packages that
I had selected.

No. Based on what you said, I don't know what the problem was. Does /var/log/setup.log.full give any clues?


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple