Web lists-archives.com

Re: setup-x86_64.exe v2.889 doesn't select additionally downloaded packages when installing from local directory




Hi Ken,

 Thanks for finding that. However, I am using the same "Local Package Directory" that I used
when I ran it to do the download. For example, here's where things were for all the steps:

1. Directory C:\Updates\cygwin_download, containing setup-x86_64.exe and nothing else
2. Ran setup, "Download without installing", specifying C:\Updates\cygwin_download as
     the local package directory, then selected additional packages and performed the download.

at this point, C:\Updates\cygwin_download contained setup-x86_64.exe and a
subdirectory for the mirror site. The setup.ini file was in a x64_64 subdirectory
under the mirror site subdirectory.

3. Then I ran setup again, "Install from local directory", with C:\cygwin64 as the root directory
     and C:\Updates\cygwin_download as the local package directory.

Should I have specified something differently for it to detect the additional packages that I
selected for download? I looked in setup.ini and it does list the additional packages that
I had selected.

Regards,
 Robert


From: cygwin-owner@xxxxxxxxxx <cygwin-owner@xxxxxxxxxx> on behalf of Ken Brown <kbrown@xxxxxxxxxxx>
Sent: Saturday, March 3, 2018 21:16
To: cygwin@xxxxxxxxxx
Subject: Re: setup-x86_64.exe v2.889 doesn't select additionally downloaded packages when installing from local directory
    
On 3/3/2018 6:00 PM, Robert Cohen wrote:
> Summary of problem:
> When installing Cygwin from a local directory, setup-x86_64.exe version 2.889 doesn't
> list the packages that I additionally selected for download when previously downloading
> to that directory, and the top line of the GUI under Category view says "No packages found<->Default".

When you run setup to do the install, you need to use the same "Local 
Package Directory" that you used when you ran it to do the download.  I 
suspect you're instead using the directory containing the packages; this 
is no longer supported as of setup version 2.883.

 From https://sourceware.org/ml/cygwin/2017-12/msg00169.html:

   - Remove support for installing from a local directory which doesn't
     contain a setup.ini file

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

    
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple