Web lists-archives.com

Re: "ls" doesn't show postscript files any longer




Hi Henri, hi Marco,

I can see my postscript file again with cygwin1-20180216.dll.

hermes temp 10 uname -a
CYGWIN_NT-6.1 hermes 2.10.1(0.325/5/3)  x86_64 Cygwin
hermes temp 11 ls -l
total 328
-rwxrwx---+ 1 SYSTEM   SYSTEM  10896 Feb 20 16:37 MpCmdRun.log
-rwxrwx---+ 1 fd1026_2 None   322294 Feb 20 16:39 chap4.ps
hermes temp 12 getfacl chap4.ps
# file: chap4.ps
# owner: fd1026_2
# group: None
user::rwx
group::---
group:root:rwx
group:Authentifizierte Benutzer:rwx
group:SYSTEM:rwx
group:Benutzer:r-x
mask:rwx
other:---

hermes temp 13

Thank you very much for your help.

Siegmar

Am 19.02.2018 um 23:34 schrieb Houder:
On Mon, 19 Feb 2018 12:24:24, Siegmar Gross wrote:
Hi,

I'm using Cygwin on top of Windows 7 (all updates installed).
"ls" doesn't show postscript files any longer after upgrading
all installed Cygwin packages to the latest versions. I create
the postscript file with MS Word 2003 using the "HP Color LJ
4550 PS" driver and printing to a file. In the past these files
were visible.

hermes temp 10 uname -a
CYGWIN_NT-6.1 hermes 2.10.0(0.325/5/3) 2018-02-02 15:16 x86_64 Cygwin
hermes temp 11 ls
MpCmdRun.log
hermes temp 12 ls *.ps
ls: No match.
hermes temp 13 ls chap4.ps
chap4.ps
hermes temp 14 file chap4.ps
chap4.ps: PJL encapsulated PostScript document text
hermes temp 15

Does anybody know why I don't see the existing file any longer?

Siegmar,

Please, do as suggested by Marco Atzeri.

  - stop everything "Cygwin" related, and
  - replace the cygwin1.dll by the one you will find here

     https://cygwin.com/snapshots/

Download https://cygwin.com/snapshots/x86_64/cygwin1-20180216.dll.xz and
extract the cygwin1.dll.

As verification of what Marco believes to be the culprit, I "printed" to a file
from Word 2007.

This file proved to be "invisible" for ls (but not to the cmd's dir command).

The Windows Explorer shows that the file has the T attribute ... You may use
properties > details to verify if the same is true for chap4.ps

After replacing the cygwin1.dll with the latest version, the file "reappeared"
again to ls.

Please, report back here (using BOTTOM-posting - as I do here).

Henri


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple