Web lists-archives.com

Re: clang dependencies

On 2018-02-13 12:07, Alberto Escrig Vidal wrote:
> Consider the following program:
> #include <iostream>
> int main() {}
> If I compile it with
> clang++ -stdlib=libc++ foo.cpp
> i get the error:
> /usr/include/c++/v1/locale:197:10: fatal error: 'nl_types.h' file not found
> #include <nl_types.h>
> The reason is that libcatgets-devel 1.1-2 was obsoleted by cygwin-devel.

It sounds like you did not update cygwin/cygwin-devel and
catgets/libcatgets-devel in sync.  Could you check:

$ cygcheck -c cygwin cygwin-devel
Cygwin Package Information
Package              Version        Status
cygwin               2.10.0-1       OK
cygwin-devel         2.10.0-1       OK

If either those say Incomplete instead of OK -- which I suspect at least
cygwin-devel will -- then reinstall that/those package(s).

> On the other hand, if I compile it with:
> clang++ -stdlib=libc++ foo.cpp

You mean clang++ -stdlib=libstdc++ here?

> it fails to link via gcc because -liconv is missing, yet I got libiconv installed.> I had to manually install libiconv-dev for libiconv.a to be in /usr/lib/.

libiconv-devel should have been pulled in by something else, but I'll
have to take a look.


Attachment: signature.asc
Description: OpenPGP digital signature