Web lists-archives.com

Re: [ANNOUNCEMENT] Test: postgresql-10.2-1




On 12/02/2018 16:17, Brian Inglis wrote:
On 2018-02-12 04:53, Marco Atzeri wrote:
On 12/02/2018 12:30, Thorsten Kampe wrote:
* Marco Atzeri (Mon, 12 Feb 2018 08:39:09 +0100)
PQencryptPasswordConn belongs to cygpq-5.dll
in libpq5-10.2-1.
libpq was still version 9.6. Shouldn't it be selected
for upgrading automatically as a dependency?
It should be upgraded.
The setup.ini "requires" is correctly reporting it.
@ postgresql-client
sdesc: "front-end programs for PostgreSQL"
ldesc: "object-relational SQL database management system"
category: Database
requires: crypt cygwin libintl8 libpq5 libreadline7 openssl zlib0

As that version 10.2-1 is also test, doesn't either that version or the Test
control need to be explicitly selected?

If test checkbox is selected,  all installed packages should be
proposed for upgrade (9.6.7-1 -> 10.2-1)

I just verified and it works as expected on both the current 2.884
and the test version 2.887 of setup.

However if you select manually the 10.2-1 of postgresql-client,
without checking the test checkbox, the 10.2-1 of libpq5 will
not be proposed for update; this happens on both versions of setup.



Regards
Marco








--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple