Web lists-archives.com

Missing dependencies for ocaml package




The dependencies for the ocaml package in the Cygwin repository are
incomplete. ocamlopt depends on the gcc-core and flexdll packages.

More precisely, ocamlopt itself depends on binutils and flexlink. flexlink
requires a C compiler, however it's also possible to use the flexdll package
without specifically needing gcc-core, so I'd suggest that it is the ocaml
package, rather than flexdll package, which requires the dependency.

Please could the maintainer add those two dependencies to setup.ini? The
alternative would be to split the ocaml package into two - for example,
ocaml and ocaml-native with only the latter depending on gcc-core and
flexdll and including the ocamlopt binary and native code libraries.

Thanks!


David


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple