Web lists-archives.com

Re: Can't link to libpopt




On Mon, 8 Jan 2018 18:53:13, Trevor Barton wrote:
Thanks Marco.  However that's marked as obsolete in the installer and replaced by libpopt-devel.  Also the version for that is 1.16.1 I think, whereas he current version is 1.16.2.  The 1.16.2 version is empty and just shows an obsolete message on cygwin.com ...

I can repro these problems:

1. popt: obsolete
2. popt-devel: obsolete
3. libpopt0: only has the DLL
4. libpopt-devel: libpopt.dll.a only
4. libpopt-common: /usr/share/doc and /usr/share/locale only
5. mingw64-x86_64-popt: has libpopt.a, but only for native builds
6. mingw64-i686-popt: has libpopt.a, but only for native builds

You might post an issue here:

http://github.com/cygwinports/popt

but good luck - Yaakov is not keen on fixing these type issues:

http://github.com/cygwinports/mingw64-x86_64-expat/issues/1
http://github.com/cygwinports/mingw64-x86_64-fdk-aac/issues/1
http://github.com/cygwinports/mingw64-x86_64-lua/issues/1
http://github.com/cygwinports/mingw64-x86_64-nghttp2/issues/1
http://github.com/cygwinports/mingw64-x86_64-pcre/issues/1


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple