Web lists-archives.com

libnet on cygwin: how to deal with libpcap?

Dear all,
I need to install libnet and I found on various sites [2][3] that the
only one way to install the prerequisite libpcap is to extract the
Developer Pack [4] into cygwin. I did it, I run all the tests and the
pcap library seemed to work pretty well. So I run the configure file
the latest available version of libnet and I was able to create the
Makefile. My problem comes running the "make" command, because the
libpcap library includes winsock2.h while libnet is based on socket.h.
Is this definitely an incompatibility between the two libraries or
there is something which can be done? Does someone know another way to
install libpcap on cygwin?


[1] https://sourceforge.net/projects/libnet-dev/
[2] https://www.unix.com/unix-for-beginners-questions-and-answers/26518
[3] https://stackoverflow.com/questions/2396251/help-installing-libpcap
[4] https://www.winpcap.org/devel.htm

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple