Web lists-archives.com

Re: tar-1.29 fails to build probably in relation with SSP

On 2017-12-06 13:14, Denis Excoffier wrote:
> I have installed the latest snapshot, dated 20171201, which includes the "export SSP functions" commit (dated 20171127).
> I'm also up to date with the packages (gcc 6.4.0 etc.). My uname -a produces:
> CYGWIN_NT-6.1-WOW PC13169 2.10.0(0.323/5/3)  i686 Cygwin
> I tried to build tar-1.29 and i get several errors, SSP-related i suppose, the first ones being:

The builtin SSP implementation does unavoidably conflict with GCC's
inferior one[1], which is the cause of these build errors.  When Cygwin
2.10 is released, then GCC will need to be rebuilt without the latter.
If you wish to test _FORTIFY_SOURCE with the current snapshot, then just
move /usr/lib/gcc/$arch-pc-cygwin/6.4.0/include/ssp out of the way.
Note, however, that any binaries so built will require a snapshot DLL at
runtime, and will not run on the 2.9 DLL.

[1] https://sourceware.org/ml/newlib/2017/msg01170.html


Attachment: signature.asc
Description: OpenPGP digital signature