Web lists-archives.com

Re: sort utility goes berzerk (x86_64)




On 2017-11-28 14:27, cyg Simple wrote:

On 2017-11-25 14:23, Houder wrote:
> Hi,
>
> Anyone seeing this as well? sort goes berzerk on my system when piped
> into
> head (or less) when it is fed with a 'specially prepared' input file.
>
>  - only happens on x86_64
>  - does not happen for 'LC_COLLATE=C sort tt | head'
>
> 'specially prepared' input file? (see bottom of post).

Anyone ** NOT ** seeing this?

`which sort` are you attempting to use?  The cygcheck file didn't say.

cyg, Doug, thanks for your interest!

Doug, I will reply to your mail (separately).

64-@@ which sort
/usr/bin/sort
64-@@ /usr/bin/sort tt | /usr/bin/head
abcde    1xxxxx0123456789
abcde    2xxxxx0123456789
abcde    3xxxxx0123456789
abcde    4xxxxx0123456789
abcde    5xxxxx0123456789
abcde    6xxxxx0123456789
abcde    7xxxxx0123456789
abcde    8xxxxx0123456789
abcde    9xxxxx0123456789
abcde   10xxxxx0123456789
  <==== prompt does not return

My original post only described the most relevant stuff. I expected that
everyone else had the same problem ...

I did not describe everything that I had tried ...

For instance:

strace -o junk sort tt | head, works
using any of the options -r, -n, -g, -h to sort, does NOT work
using the option -f to sort, does work

Consequently, I was a bit confused by the results. That is why I wanted
to know whether or not I was the only one with this problem.

... if I am the only one with this problem, I have to dig deeper (or let
it go).

Henri

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple