Web lists-archives.com

Re: setup.ini has multiple "prev" entries ... Why?




On 05/11/2017 18:04, Houder wrote:
On 2017-11-05 18:32, Houder wrote:
On 2017-11-05 13:48, Houder wrote:
Currently, I am only interested in the _specification_ that you have
in mind for setup.ini ...

I try to keep [1] accurate and up-to-date, but the 'specification' is really "what setup accepts" :(

Currently, the ordering requirements are:

1) The version to be installed when test versions are selected (the highest test, unless one is explicitly specified in override.hint) is the last [test] section

2) [curr] is first

But since both these things are to work around historical setup limitations, I don't think they merit mention in [1], and might not be the case in a future when we no longer care about setup versions old enough to need them.

[1] https://sourceware.org/cygwin-apps/setup.ini.html

Another (edited) snippet from setup.ini: (where the latest test entry is
not the last entry (of the "test" entries ?????)

@ xorg-server-common
sdesc: "X.Org X server common data"
ldesc: "X.Org X server common data"
category: X11
requires: dri-drivers perl_base xauth xcursor-themes xkbcomp xkeyboard-config
version: 1.19.5-1 <- current
...
[test]
version: 1.19.3-2 <==== latest test?
...
[test]
version: 1.19.3-1
...

Thanks for pointing this out. This is due to a 'bug', which caused incorrect ordering of test versions lower than curr.

That should be fixed now, but please let me know if you notice any other problems.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple