Web lists-archives.com

Stow not working since perl 5.26 upgrade




Hi,

Recently I tried to use the "stow" command from the stow and perl-Stow
packages and found it does not work. It does not even print the help
or version:

$ stow --version
Can't locate Stow.pm in @INC (you may need to install the Stow module)
(@INC contains:
/usr/local/lib/perl5/site_perl/5.26/x86_64-cygwin-threads
/usr/local/share/perl5/site_perl/5.26
/usr/lib/perl5/vendor_perl/5.26/x86_64-cygwin-threads
/usr/share/perl5/vendor_perl/5.26
/usr/lib/perl5/5.26/x86_64-cygwin-threads /usr/share/perl5/5.26) at
/usr/bin/stow line 418.
BEGIN failed--compilation aborted at /usr/bin/stow line 418.

The current perl version is 5.26, but it seems stow is installed under
a directory for an older version of perl:

$ ls /usr/lib/perl5/vendor_perl/5.22
Stow  Stow.pm

I worked around by setting a temporary environment variable:

$ export PERL5LIB=/usr/lib/perl5/vendor_perl/5.22
$ stow --version
stow (GNU Stow) version 2.2.2

Maybe the stow module should be repackaged for the new installation
path? I remember the stow command used to work several months ago,
which is before perl is upgraded to 5.26.

I'm using Cygwin on Windows 10 (64 bit, Japanese locale). The package
versions on my Cygwin setup are:
cygwin 2.9.0-3
perl 5.26.1-1
stow 2.2.2-1
perl-Stow 2.2.2-1

Thanks!
-- 
Watanabe, Yuki <magicant.wonderwand@xxxxxxxxx>

Attachment: cygcheck.out
Description: Binary data

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple