Web lists-archives.com

Re: setup.ini has multiple "prev" entries ... Why?




On 2017-11-05 18:32, Houder wrote:
On 2017-11-05 13:48, Houder wrote:
Hi John (Turney),

After I had downloaded and exercised setup version 2.882, I noticed
that setup.ini has multiple (2?) "prev" entries per package ...

Why? Did I miss one of your announcements mentioning this change?

Jon,

    https://cygwin.com/ml/cygwin-apps/2017-10/msg00047.html

Because of the way setup works, the last [test] section is the version which is selected when 'test' is selected, so a specific ordering of the sections
 would be required. ...

Jon,

Currently, I am only interested in the _specification_ that you have
in mind for setup.ini ...

Regards,

Henri

Another (edited) snippet from setup.ini: (where the latest test entry is
not the last entry (of the "test" entries ?????)

@ xorg-server-common
sdesc: "X.Org X server common data"
ldesc: "X.Org X server common data"
category: X11
requires: dri-drivers perl_base xauth xcursor-themes xkbcomp xkeyboard-config
version: 1.19.5-1 <- current
...
[test]
version: 1.19.3-2 <==== latest test?
...
[test]
version: 1.19.3-1
...
[prev]
version: 1.19.2-1
...
[prev]
version: 1.19.1-1
...
[prev]
version: 1.18.4-1
...
[prev]
version: 1.19.4-1 <==== latest prev?
...

@ xorg-server-devel
sdesc: "X.Org SDK for developing drivers and extensions for the Xorg X server" ldesc: "X.Org SDK for developing drivers and extensions for the Xorg X server"
category: X11
requires: fontsproto inputproto kbproto libpixman1-devel pkg-config ...
version: 1.19.5-1 <- current
...
[test]
version: 1.19.3-2 <==== latest test?
...
[test]
version: 1.19.3-1
...
[prev]
version: 1.19.2-1
...
[prev]
version: 1.19.1-1
...
[prev]
version: 1.18.4-1
...
[prev]
version: 1.19.4-1 <==== latest prev?
...

=====

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple