Web lists-archives.com

Re: cygwin x86 setup issue:Can't connect to (null):80




On 26/10/2017 21:40, Jon Turney wrote:
On 26/10/2017 16:52, Fergus wrote:
.. we are using our internal cygwin mirror
.. when we setup x86-setup.exe .. it show download incomplete ..
I thought perhaps setup couldn't handle a nonstandard port ..

Not quite certain what is going on but something is, possibly related
to the latest recent up-versioning of the setup-x86 executable to
2.882?

Since the OPs first mail about their problem (2017-10-15) pre-dates the release of setup 2.882 (2017-10-24), this seems unlikely unless OP is in possession of a time-machine.

Forever I have updated Cygwin using a Command Prompt window and the
typed command
setup-x86.exe -L D:\cyg -R D:\consoleX -gqnm
where the key switches are to update to the Cygwin provision located
at D:\consoleX from a local mirror located at D:\cyg.
(Previously I will have updated x86\setup.ini and x86\setup.ini.sig
and augmented x86\release\ so that everything is in place that is
needed.)

I'm not sure what this means.

There should be no way for you to generate a valid setup.ini.sig (absent possession the Cygwin signing key, or using --no-verify, or using --pubkey to provide an additional key), assuming the setup validates that signature in --local-package-dir mode, which I think it should be.

Oh, I get it. You're just saying you update the (partial?) mirror in 'D:\cyg'. Sorry for the misunderstanding.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple