Web lists-archives.com

Re: cygwin x86 setup issue:Can't connect to (null):80




On 2017-10-25 13:52, Lynn Lin wrote:
>> On 2017-10-24,9:23,Jon Turney <jon.turney@xxxxxxxxxxxxxxxx> wrote:
>>> On 15/10/2017 02:39, Lynn Lin wrote:
>>> we are using our internal cygwin mirror(xx.xx.xx.xx:8000) and when we
>>> setup setup-x86.exe, it is in cygwin setup ui, show downloading and
>>> connecting, finally it show download incomplete, through the log, it
>>> shows:
>>> Can’t connect to (null):80 ,
>>> get_url_to_file failed !
>>> any idea about this issue?
>>
>> I thought perhaps setup couldn't handle a nonstandard port, but in my 
>> testing, that seems to work ok.
>>
>> Can you provide a /var/log/setup.log.full showing this problem? (censoring 
>> any details you don't want to make public)
> Thanks, no log available is right now
> We are using golang net/http to setup a http file share in OSX and looks it 
> can’t handle “//“ for Cygwin packages path like http://xx.xx/cywin//x86/xx> And when we try python simple http server package and it works
Remove the extra slash above ...//... between cygwin and x86:
	http://cygwin.mirror.local:port/cygwin/x86/...
	                                      ^
as some Internet libraries and/or servers do not handle that by removing the
extra slash.

Best to paste the actual log content into the email or attach the log as text.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple