Web lists-archives.com

Re: [ANNOUNCEMENT] lz4 1.7.5-1




On 2017-10-01 10:31, S. Loiseau wrote:
> On Sun, 03 Sep 2017 21:02:44 -0500, Yaakov Selkowitz wrote:
>> The following packages have been uploaded to the Cygwin distribution:
>>
>> * liblz4_1-1.7.5-1
> 
> My setup-x86_64 (version 2.881 from 2017-07-05) does not upgrade to this new 
> version.
> My liblz4_1 is at version 131-1 and setup propose to "Keep" it. It does not 
> appear on "Pending" view.
> 
> Maybe some comparison inside setup.exe think that "1.7.5-1" <= "131-1" ?
> 
> Other updates were proposed and executed.
> Version 1.7.5-1 is proposed by clicking 3 times on "Keep" (after "Reinstall"
> and "Uninstall").
> 
> Below the setup.ini part, showing 1.7.5-1 as "Current" and 131-1 as "Prev"
>
> # This file was automatically generated at 2017-09-30 05:38:39 UTC.
> release: cygwin
> arch: x86_64
> setup-timestamp: 1506749919
> setup-version: 2.881
> 
> @ liblz4_1
> sdesc: "LZ4 de/compressor"
> version: 1.7.5-1
> install: x86_64/release/lz4/liblz4_1/liblz4_1-1.7.5-1.tar.xz 30408
> source: x86_64/release/lz4/lz4-1.7.5-1-src.tar.xz 210608
> [prev]
> version: 131-1
> install: x86_64/release/lz4/liblz4_1/liblz4_1-131-1.tar.xz 17924
> source: x86_64/release/lz4/lz4-131-1-src.tar.xz 136668

Version number format changes often require manual intervention to upgrade, as
in this case.

> Output of cygcheck -s -r -v attached.
> 
> Thank you for the great tool!

Cygwin setup developers are testing a new upgrade approach.
Can any of the setup developers comment on whether that will fix this issue?

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple