Web lists-archives.com

Re: Problems with building Perl modules after upgrade to g++ (GCC) 6.4.0




On Mon, Sep 11, 2017 at 11:51 AM, Achim Gratz wrote:

> Unless you know what you're doing and can navigate the inevitable
> obstacles, do not use cpan on Cygwin.

I have been building Perl packages for years without problems.  I use
WWW::Mechanize in several programs, and it has a lot of
pre-requisites.

>> SSLeay.xs:163:25: fatal error: openssl/err.h: No such file or directory
>>  #include <openssl/err.h>
>
> The most likely reason is that you do not have the *-devel package for
> openssl installed.

Missed that, thanks!


I don't know why Cygwin "upgraded" me from Perl 5.22 to Perl 5.24.  I
am building a new Cygwin installation from scratch (via setup) and it
has Perl 5.22 (as expected) and gcc 6.4.  I seem to remember this
problem happening in the not-too-distant past when gcc 6.x was
experimental, so I probably picked up the experimantal Perl 5.24 as
well.  I tried to roll back Perl from 5.24 -> 5.22 in my existing
Cygwin (non-experimental) installation but "perl --version" still
returned version 5.24

Anyway, I'll have a clean installation soon, I hope.

- Jim

-- 
Jim Reisert AD1C, <jjreisert@xxxxxxxxxxxx>, http://www.ad1c.us

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple