Web lists-archives.com

Strange errors with gcc and top, even after rebaseall




Hi,
 

i had some strange errors with Cygwin (32bit) and installed it new (all, every package), but even after "/usr/bin/rebase-trigger full" and setup two errors are remaining:
 
1.) top does exit at startup with return code -1. Afterwards everything entered is black, as the background, and backspace is displayed as quadgraph "\177".
 
2.) Linking is not possible, even with a small hello world program:

> make
gcc -o hello.exe hello.o
/usr/lib/gcc/i686-pc-cygwin/5.4.0/../../../../i686-pc-cygwin/bin/ld: unrecognized option '-plugin'
/usr/lib/gcc/i686-pc-cygwin/5.4.0/../../../../i686-pc-cygwin/bin/ld: use the --help option for usage information
collect2: Fehler: ld gab 1 als Ende-Status zurueck
make: *** [makefile:6: hello.exe] Fehler 1

 > gcc -fno-use-linker-plugin -o hello.exe hello.o
/usr/lib/gcc/i686-pc-cygwin/5.4.0/../../../../i686-pc-cygwin/bin/ld: unrecognized option '--build-id'
/usr/lib/gcc/i686-pc-cygwin/5.4.0/../../../../i686-pc-cygwin/bin/ld: use the --help option for usage information
collect2: Fehler: ld gab 1 als Ende-Status zurueck

> cat makefile
TARGET    = hello.exe
OBJECT_01 = hello.o
SOURCE_01 = hello.c
$(TARGET): $(OBJECT_01)
        gcc -o $(TARGET) $(OBJECT_01)
$(OBJECT_01) : $(SOURCE_01)
        gcc -c $(SOURCE_01) -o $(OBJECT_01)
all : $(TARGET)
clean :
        -rm $(TARGET) $(OBJS)
 

What should i do to eleminate these errors?
 
Regards,
 
Rolf

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple