Web lists-archives.com

`rescue in block in dlload': can't load user32 (Fiddle::DLError) on running cap




Hi,

I installed Capistrano and am facing problems white executing the cap
command.  The OS is Windows 2012 R2.
So when I run,

cap <<>> deploy,

 the error displayed is,

/usr/share/ruby/2.3.0/fiddle/import.rb:86:in `rescue in block in
dlload': can't load user32 (Fiddle::DLError)
        from /usr/share/ruby/2.3.0/fiddle/import.rb:83:in `block in dlload'
        from /usr/share/ruby/2.3.0/fiddle/import.rb:74:in `collect'
        from /usr/share/ruby/2.3.0/fiddle/import.rb:74:in `dlload'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:59:in
`<module:Win>'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:41:in
`<module:Pageant>'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:33:in
`<module:Authentication>'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:24:in
`<module:SSH>'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:24:in
`<module:Net>'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/pageant.rb:24:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/agent.rb:9:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/key_manager.rb:4:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh/authentication/session.rb:4:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-4.0.1/lib/net/ssh.rb:12:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/net-ssh-gateway-2.0.0/lib/net/ssh/gateway.rb:2:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/capistrano-2.15.9/lib/capistrano/configuration/connections.rb:2:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/capistrano-2.15.9/lib/capistrano/configuration.rb:5:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/capistrano-2.15.9/lib/capistrano.rb:3:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/capistrano-2.15.9/lib/capistrano/cli.rb:1:in
`<top (required)>'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:55:in
`require'
        from /home/Administrator/.gem/ruby/2.3.0/gems/capistrano-2.15.9/bin/cap:3:in
`<top (required)>'
        from /home/Administrator/bin/cap:23:in `load'
        from /home/Administrator/bin/cap:23:in `<main>'


My gem environment info is given below -

RubyGems Environment:
  - RUBYGEMS VERSION: 2.6.12
  - RUBY VERSION: 2.3.3 (2016-11-21 patchlevel 222) [x86_64-cygwin]
  - INSTALLATION DIRECTORY: /home/Administrator/.gem/ruby/2.3.0
  - USER INSTALLATION DIRECTORY: /home/Administrator/.gem/ruby/2.3.0
  - RUBY EXECUTABLE: /usr/bin/ruby.exe
  - EXECUTABLE DIRECTORY: /home/Administrator/bin
  - SPEC CACHE DIRECTORY: /home/Administrator/.gem/specs
  - SYSTEM CONFIGURATION DIRECTORY: /etc
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-cygwin
  - GEM PATHS:
     - /home/Administrator/.gem/ruby/2.3.0
     - /usr/share/gems
     - /usr/local/share/gems
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - https://rubygems.org/
  - SHELL PATH:
     - /usr/local/bin
     - /usr/bin

And the gem list is  -

*** LOCAL GEMS ***

builder (3.2.2)
capistrano (2.15.9)
capistrano-ext (1.2.1)
capistrano_rsync_with_remote_cache (2.4.0)
did_you_mean (1.0.2)
highline (1.7.8)
io-console (0.4.6)
json (1.8.6)
minitest (5.10.1)
net-scp (1.2.1)
net-sftp (2.1.2)
net-ssh (4.0.1)
net-ssh-gateway (2.0.0)
psych (2.2.4)
railsless-deploy (1.1.2)
rake (11.3.0)
rdoc (4.3.0)


Please advise.


Kind Regards,
Ashley

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple