Web lists-archives.com

Re: Emacs 25.2.1 Fails to Start Server




On 7/28/2017 5:57 PM, Erik Knowles wrote:
> 
> I just upgraded from Emacs 24.x to 25.2.1 (via installing all available cygwin updates, including Emacs). Now I find that my Emacs server start hangs after processing my .emacs file but before creating the server socket (it creates the directory used to store the socket information file, but the file itself is not created).
> 
> My normal server start, run from a Windows shortcut, is:
> 
> C:\cygwin\bin\bash -c 'emacsclient -n -c --alternate-editor=""&'

I wouldn't expect this to work, because of the '&'.  Here's what I see when I run that command interactively:

$ emacsclient -n -c --alternate-editor=""&
[1] 10404

$ ps
      PID    PPID    PGID     WINPID   TTY         UID    STIME COMMAND
[...]
S   10404    6660   10404       9300  pty0      197609 14:21:41 /usr/bin/emacsclient-X11

Putting emacsclient in the foreground makes it run as expected:

$ fg
emacsclient -n -c --alternate-editor=""
emacsclient: can't find socket; have you started the server?
To start the server in Emacs, type "M-x server-start".

[...]
Starting Emacs daemon.
Restarting server
Emacs daemon should have started, trying to connect again

$ ps
      PID    PPID    PGID     WINPID   TTY         UID    STIME COMMAND
     6660    6396    6660       8836  pty0      197609 16:19:49 /usr/bin/bash
    10932    6660   10932       7860  pty0      197609 14:24:24 /usr/bin/ps
     3620       1    3620       3620  ?         197609 14:23:27 /usr/bin/emacs-X11

$ ps
      PID    PPID    PGID     WINPID   TTY         UID    STIME COMMAND
[...]
    3620       1    3620       3620  ?         197609 14:23:27 /usr/bin/emacs-X11

$ ls -l /tmp/emacs197609/
total 1
srw------- 1 kbrown None 0 2017-07-31 14:23 server=

And just running emacsclient in the foreground to begin with also works as expected for me.

> emacs --daemon -q

This works fine for me also:

$ emacs-w32 --daemon -q
Starting Emacs daemon.

$ ps
      PID    PPID    PGID     WINPID   TTY         UID    STIME COMMAND
[...]
     6744       1    6744        228  ?         197609 14:28:58 /usr/bin/emacs-w32

$ ls -l /tmp/emacs197609/
total 1
srw------- 1 kbrown None 0 2017-07-31 14:28 server=

Your cygcheck output shows two cygwin1.dlls in your path:

3373k 2017/07/12 D:\cygwin\bin\cygwin1.dll - os=4.0 img=1.0 sys=4.0
                  "cygwin1.dll" v0.0 ts=2017-07-12 09:53
    Cygwin DLL version info:
        DLL version: 2.8.2
[...]
 2586k 2010/08/31 \\a1\utils\cygwin1.dll - os=4.0 img=1.0 sys=4.0
                  "cygwin1.dll" v0.0 ts=2010-08-31 08:58
    Cygwin DLL version info:
        DLL version: 1.7.7
[...]
Warning: There are multiple cygwin1.dlls on your path

I don't know if this could cause the problems you're seeing, but could you try removing \\a1\utils from your path and see if that helps?

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple