Web lists-archives.com

Re: Emacs + run.exe problem.




On 2017-07-30, Oleksandr Gavenko wrote:
>
> This time two new:

I tried with 32-bit version.

As 64-bit version better avoid rebase problems I tried it.

> * "run emacs-w32" is broken. Some GUI windows splashed on screen and quickly
>   hid. 
>
Stil broken.

> * during work if emacs-w32 I see in consle (it's before and after after rebaseall):
>
>   1 [main] emacs-w32 936 child_info_fork::abort: C:\opt\cygwin\bin\cygXrender-1.dll: Loaded to different address: parent(0x1C50000) != child(0x6D520000)
>
>   1 [main] emacs-w32 1624 child_info_fork::abort: C:\opt\cygwin\bin\cygXrender-1.dll: Loaded to different address: parent(0x6D520000) != child(0x1E0000)

Don't get anymore.

But in addition socket binding for Emacs server stopped to work:

  (server-start)

with:

  Debugger entered--Lisp error: (file-error "Cannot bind server socket" "No such file or directory")
    make-network-process(:name "server" :server t :noquery t :sentinel server-sentinel :filter server-process-filter :coding raw-text-unix :family local :service "/tmp/emacs197609/server" :plist (:authenticated t))
    apply(make-network-process :name "server" :server t :noquery t :sentinel server-sentinel :filter server-process-filter :coding raw-text-unix (:family local :service "/tmp/emacs197609/server" :plist (:authenticated t)))
    server-start()

>From past expirience I know workaround:

  (if (eq system-type 'cygwin)
      (setq server-use-tcp t))

================================================================

Unfortunetely there are too many problems with Cygwin W32 build to be useful.
The most distracting is a fork problems.

I'll back to native Emacs with cygwin.el. That combination has worked for me
since 2007.

-- 
http://defun.work/


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple