Web lists-archives.com

Re: how to access and display apps that I've launched




On 24/07/2017 23:08, Ian Lambert via cygwin wrote:
On Mon, 7/24/17, Ken Brown <> wrote:

  Subject: Re: how to access and display apps that I've launched
  To: "Ian Lambert" <>, cygwin@xxxxxxxxxx
  Date: Monday, July 24, 2017, 3:51 PM
On 7/24/2017 12:08 PM, Ian
  Lambert wrote:
  > On Sun, 7/23/17, Ken
  Brown <> wrote:
  >   Yes, there was
  a change about
  >   two years ago.  I
  suspect you have a
  >   .startxwinrc that
  uses fbpanel instead of
  >
  xwin-xdg-menu.  See
  >
  >      https://sourceware.org/ml/cygwin-announce/2015-07/msg00013.html
  >
  >   Ken,
  >
  >
  > I have a relatively new install, since pi
  day 2017, and no .startxwinrc.
  >
  > I had something similar Thursday 7/20/17
  afternoon, after running updates
  > for
  Windows security, and Cygwin.
Mike's description of his problem suggests
  that he was using fbpanel.
  He refers to an
  icon at the top middle of the screen, not the
  xwin-xdg-icon in the notification area.  Your
  description is different,
  and at least one
  of your error messages (gedit 8876
  child_info_fork::abort:...) sounds like a
  rebase issue.
Ken
It's not a .startxwinrc problem because I don't have one. Also I was trying to access the apps from the notification area I just wasn't calling it the right thing. I wasn't trying to access anything by the very top icon. In the notification area among other things you can get an XDG Menu.

Thanks, Mike
= = =

Please let me know if this should be a different thread then,
but it seemed similar and timing was coincidental.

When I did
run "rebase-trigger full" then run setup-x86
(or x86_64) the first time, I had not shut down all cygwin processes between
trigger full and setup.
This time I ran "rebase-trigger full", did full shutdown/restart, then ran setup.

This time xterm will not start from the xwin-xdg-menu, but will start from
command line (after export DISPLAY=:0.0).

I saw these from $ startxwin &

(WW) /tmp mounted on a filesystem without hardlinks, activating -nolock
_XSERVTransmkdir: Mode of /tmp/.X11-unix should be set to 1777
_XSERVTransmkdir: this may cause subsequent errors


and some rebase-related touch error messages in setup.log.full:

  2017/07/24 17:24:08 running: E:\cygwin64-3\bin\dash.exe "/etc/postinstall/0p_000_autorebase.dash"
Note: _autorebase will do a full rebase the next time setup is run.
removing /var/cache/rebase/rebase_pkg
creating empty /var/cache/rebase/rebase_pkg
touch: setting times of '/var/cache/rebase/rebase_pkg': Invalid argument
Updating package information in /var/cache/rebase/rebase_pkg.
removing /var/cache/rebase/rebase_lst
creating empty /var/cache/rebase/rebase_lst
touch: setting times of '/var/cache/rebase/rebase_lst': Invalid argument
Updating rebase information for installed executables in /var/cache/rebase/rebase_exe.
removing /var/cache/rebase/rebase_dyn
creating empty /var/cache/rebase/rebase_dyn
touch: setting times of '/var/cache/rebase/rebase_dyn': Invalid argument
Looking for dynamic language modules/libraries in:
   /usr/lib/R/site-library
   /usr/lib/php/20151012
   /usr/lib/python2.7/site-packages
   /usr/lib/python3.6/site-packages
Updating rebase information for dynamic language modules/libraries /var/cache/rebase/rebase_dyn.
removing /var/cache/rebase/rebase_user
creating empty /var/cache/rebase/rebase_user
touch: setting times of '/var/cache/rebase/rebase_user': Invalid argument
Updating rebase information for user-defined dynamic objects /var/cache/rebase/rebase_user.
removing /var/cache/rebase/rebase_user_exe
creating empty /var/cache/rebase/rebase_user_exe
touch: setting times of '/var/cache/rebase/rebase_user_exe': Invalid argument
Updating rebase information for user-defined executables /var/cache/rebase/rebase_user_exe.
Rebasing with list /var/cache/rebase/rebase_all, built from /var/cache/rebase/rebase_lst /var/cache/rebase/rebase_dyn /var/cache/rebase/rebase_user.
2017/07/24 17:24:23 running: E:\cygwin64-3\bin\dash.exe "/etc/postinstall/0p_texlive_prep.dash"
2017/07/24 17:24:23 running: E:\cygwin64-3\bin\dash.exe "/etc/postinstall/0p_update-info-dir.dash"
2017/07/24 17:24:25 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_adwaita-icon-theme.sh"
2017/07/24 17:24:26 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_desktop-file-utils.sh"
2017/07/24 17:24:26 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_fontconfig_cache_1.sh"
2017/07/24 17:25:30 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_glib2.0.sh"
2017/07/24 17:25:31 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_hicolor-icon-theme.sh"
2017/07/24 17:25:31 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_man-db.sh"
2017/07/24 17:25:33 running: E:\cygwin64-3\bin\dash.exe "/etc/postinstall/zp_octave_finish.dash"
2017/07/24 17:25:33 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_shared-mime-info.sh"
2017/07/24 17:25:34 running: E:\cygwin64-3\bin\dash.exe "/etc/postinstall/zp_texlive_finish.dash"
2017/07/24 17:25:34 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/zp_units_cur.sh"
Error connecting to currency server. <urlopen error [Errno 8] Name or service not known>


About half the "accessory" app's won't start from the xdg menu, and throw fork errors when started
from the xterm command line. For example:


   0 [main] nautilus 3240 child_info_fork::abort: E:\cygwin64-3\bin\cygpangocairo-1.0-0.dll: Loaded to different address: parent(0x3F0000) != child(0x2F0000)
       0 [main] nautilus 3396 child_info_fork::abort: E:\cygwin64-3\bin\cygpangocairo-1.0-0.dll: Loaded to different address: parent(0x3F0000) != child(0x2F0000)
       0 [main] nautilus 5840 child_info_fork::abort: E:\cygwin64-3\bin\cygpangocairo-1.0-0.dll: Loaded to different address: parent(0x3F0000) != child(0x400000)

(nautilus:6936): GLib-GIO-CRITICAL **: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(nautilus:6936): GLib-GIO-CRITICAL **: g_dbus_proxy_get_name_owner: assertion 'G_IS_DBUS_PROXY (proxy)' failed
       0 [main] nautilus 2364 child_info_fork::abort: E:\cygwin64-3\bin\cygxml2-2.dll: Loaded to different address: parent(0x580000) != child(0x570000)
       0 [main] nautilus 2900 child_info_fork::abort: E:\cygwin64-3\bin\cygpangocairo-1.0-0.dll: Loaded to different address: parent(0x3F0000) != child(0x500000)
Failed to connect to socket /tmp/fam-myuser/fam-

(nautilus:6936): dconf-WARNING **: failed to commit changes to dconf: Failed to fork (Resource temporarily unavailable)

(nautilus:6936): dconf-WARNING **: failed to commit changes to dconf: Failed to fork (Resource temporarily unavailable)

** (nautilus:6936): WARNING **: Unable to get contents of the bookmarks file: Error opening file /home/myuser/.gtk-bookmarks: No such file or directory

(nautilus:6936): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(nautilus:6936): dconf-WARNING **: failed to commit changes to dconf: Failed to fork (Resource temporarily unavailable)

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



--
I *AM* a unique and special snowflake


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple