Web lists-archives.com

Re: GCC Compiler can't seem to find linker




Interesting that the package name isn't "libarchive" in the repos, but it's "libarchive13". Since I'm using a apt-get bash script to get the packages for me anyway. Since it seems I already had "libarchive13" installed, I tried installing the mingw64 package to see if it would fix my issue building another package, but it didn't seem to find it still, even after restarting the shell, so I'm not exactly sure how to get this to detect libarchive.

This output from the last 4 lines of ./configure of the msys2-pacman package.

...
checking pkg-config is at least version 0.9.0... yes
checking for LIBARCHIVE... no
configure: error: *** libarchive >= 2.8.0 is needed to compile pacman!
configure: WARNING: cache variable lt_cv_path_LD contains a newline

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple