Web lists-archives.com

Re: Any progress on making biber work?




On 6/24/2017 7:41 AM, Леон Майер wrote:
As of now, biber does not work:
[
$ biber
Can't locate Log/Log4perl.pm in @INC (you may need to install the Log::Log4perl module) (@INC contains: /usr/lib/perl5/site_perl/5.24/x86_64-cygwin-threads /usr/lib/perl5/site_perl/5.24 /usr/lib/perl5/vendor_perl/5.24/x86_64-cygwin-threads /usr/lib/perl5/vendor_perl/5.24 /usr/lib/perl5/5.24/x86_64-cygwin-threads /usr/lib/perl5/5.24 .) at /usr/bin/biber line 14.

You're using the *test* release of perl-5.24, but all the Perl modules you have were built for perl-5.22. biber will work if you revert perl to the *current* release, perl-5.22.

Now, I know that Ken said on 2017-06-04 that biblatex+biber were not in a working condition then. Has there been any progress on this so far? Perl already has version 5.24...

I didn't say they were not in working condition. I said that I couldn't update them to the latest releases. Everything should still work if you use the current (not test) releases.

Achim has said that he will update Perl (and the Perl modules) to 5.26 in late June or early July:

  https://cygwin.com/ml/cygwin-apps/2017-06/msg00000.html

When that happens, I'll update biber to the latest release and I'll remove the "test" designation from texlive-collection-bibtexextra.

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple