Web lists-archives.com

run.exe + conhost + emacs-w32 / emacsclient-w32 problem.




>From some time I can't run emacs-w32 / emacsclient-w32 via run.exe from
cmd.exe or mintty.exe.

Actually at the end I use chain of call:

  ``e.bat`` with: run.exe --quote emacsclient-w32 -a e
  ``e`` with:     cygstart --action=runas run emacs-w32

and then:

  run --quote emacsclient-w32 ...

Now I have a problem to run directly:

  run emacs-w32 -Q

during Windows 10 boot process, in first 1-2 min after boot from Win+R or cmd.

After that period of time I am able to start Emacs from Win+R "run emacs-w32 -Q".

It opens only from second time from cmd.exe on: run emacs-w32 -Q

It never opens from mintty on: run emacs-w32 -Q

Procmon showed that:

* 'run' creates 'conhost'
* 'run' creates 'emacs-w32'
* 'conhost' exits
* 'run' exits
* 'emacs-w32' exits

I see no any strange calls in procmon.

The most dangerous what was done is "Windows 10 Creators Update" after which I
started notice problems.

Previously in this list I asked about adding -mwindows to emacs-w32 build
process but that can lead to unknown errors so developers refused that option.

So I need to `run.exe` to hide console because it pollutes Alt+TAB menu as
additional useless item.

I believe that reason for emacs "failure" is exit of 'conhost'.

Any suggestion?

-- 
http://defun.work/


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple