Web lists-archives.com

Re: configure fails on checking ino_t




Aha! just slightly later in config.log:

configure:17957: checking for ino_t 
configure:17957: gcc -c -g -O2  conftest.c >&5 
configure:17957: $? = 0 
configure:17957: gcc -c -g -O2  conftest.c >&5 
conftest.c: In function 'main': 
conftest.c:94:20: error: expected expression before ')' token 
if (sizeof ((ino_t))) 
^ 
configure:17957: $? = 1 
configure: failed program was: 
| /* confdefs.h */ 
| #define PACKAGE_NAME "geomview" 


this is with:


It was created by geomview configure 1.9.5, which was 
generated by GNU Autoconf 2.69.  Invocation command line was 

$ ./configure 

thanks for the hint, but still puzzled as to why this starts
failing now.
 
Lloyd Wood lloyd.wood@xxxxxxxxxxx http://about.me/lloydwood 



________________________________
From: Lloyd Wood <lloyd.wood@xxxxxxxxxxx>
To: Csaba Raduly <rcsaba@xxxxxxxxx>; cygwin list <cygwin@xxxxxxxxxx> 
Sent: Thursday, 8 June 2017, 6:37
Subject: Re: configure fails on checking ino_t



hi Csaba

that part of config.log is not interesting:

[..]
configure:17948: result: yes
configure:17957: checking for ino_t
configure:17957: gcc -c -g -O2  conftest.c >&5
configure:17957: $? = 0
configure:17957: gcc -c -g -O2  conftest.c >&5

[..]

I'm very puzzled. But don't run Cygwin setup in
case it breaks your setup, is my thought...

thanks 
Lloyd Wood lloyd.wood@xxxxxxxxxxx http://about.me/lloydwood 



________________________________

From: Csaba Raduly <rcsaba@xxxxxxxxx>
To: Lloyd Wood <lloyd.wood@xxxxxxxxxxx>; cygwin list <cygwin@xxxxxxxxxx> 
Sent: Thursday, 8 June 2017, 5:10
Subject: Re: configure fails on checking ino_t



Hi Lloyd,

On Wed, Jun 7, 2017 at 8:21 AM, Lloyd Wood wrote:
> download geomview 1.9.5 from http://www.geomview.org
> this used to build on cygwin 32-bit. Did so for a number of years. Now, it doesn't,
> because something changed.
>
> $ tar xvfz geomview-1.9.5.tar.gz
> $ cd geomview-1.9.5
> ./configure
> [..]
> checking for dev_t... yes
> checking for ino_t... yes
> checking for time_t... yes
> checking size of dev_t... 4
> checking size of ino_t... configure: error: in `/home/ellowoo/savi/geomview-1.9.5':
> configure: error: cannot compute sizeof (ino_t)
> See `config.log' for more details
>
>
> $ tail config.log
> [..]
> #define TIME_WITH_SYS_TIME 1
> #define HAVE_M_PI 1
> #define HAVE_DEV_T 1
> #define HAVE_INO_T 1
> #define HAVE_TIME_T 1
> #define SIZEOF_DEV_T 4
>
> configure: exit 77
>
> Okay, so what changed in Cygwin?


I hope nothing, because it works for me:


checking for dev_t... yes
checking for ino_t... yes
checking for time_t... yes
checking size of dev_t... 4
checking size of ino_t... 8
checking size of time_t... 8
checking size of long... 8
checking size of int... 4


You should at least post the relevant part from config.log (the part
beginning with

configure:17957: checking for ino_t

).



Csaba
-- 
GCS a+ e++ d- C++ ULS$ L+$ !E- W++ P+++$ w++$ tv+ b++ DI D++ 5++
The Tao of math: The numbers you can count are not the real numbers.
Life is complex, with real and imaginary parts.
"Ok, it boots. Which means it must be bug-free and perfect. " -- Linus Torvalds
"People disagree with me. I just ignore them." -- Linus Torvalds

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple