Web lists-archives.com

Re: two installer questions




On 31/05/2017 03:30, Lloyd Wood via cygwin wrote:
1. setting up new cygwin X server, got stuff installed
by selecting xinit in installer and letting it pull things
in. (oddly, selecting xterm instead does not pull in
everything as I expected.)

You need to amend your expectations.

It's policy that X clients do not require the X server, as you may be using a different X server, or using the X clients remotely.

But why is adwaita-icon-theme a necessary dependency for xinit?
I'm not installing gnome...

The depchain is xinit -> xwin-xdg-menu -> adwaita-icon-theme

The package provides some icons used by xwin-xdg-menu.

2. I previously deliberately installed the older Tcl/Tk 8.5.18
instead of 8.6. rerunning the installer to add in more X stuff
automagically updated to 8.6 again. Shouldn't a specific
version chosen in a previous install be sticky somehow,
or ask if an update is desired? The ability to freeze selected
packages while everything else updates, and know about it,
seems useful to me.

If you select "Keep" rather than "Current" at the top of the package picker, you should be able to choose additional packages for installation without upgrading existing packages.

But yes, marking package versions which are explicitly selected to be held at that version would be a good idea...

... such a good idea it was added to the setup wishlist in 2003 [1]. It's a pity that in the intervening ~14 years nothing has happened, but there you are.

[1] https://sourceware.org/git/gitweb.cgi?p=cygwin-setup.git;a=commitdiff;h=3c206e03b9ffc27cff4f8a925390f57ba1f9f83f

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple