Web lists-archives.com

Re: Composer segfault on multiple configurations




Thanks Richard, you've hit the nail right on the head.
Running PHP on that specific file does produce the segfault.

I'm currently running composer via "Bash on Ubuntu on Windows". I may
compile PHP from cygports later but currently I need to make up for
lost time at work over this.
Any idea when your fix will get released as an official cygwin PHP package?

Thanks again.

On Wed, May 17, 2017 at 11:24 PM, Richard H Lee
<ricardohenrylee@xxxxxxxxx> wrote:
> On 17/05/2017 20:17, Sky Diver wrote:
>>
>> Running "composer install" with the following composer.json ends up in
>> a segmentation fault.
>>
>> ---------- START -----------
>> {
>>      "require": {
>>          "propel/propel": "~2.0@dev"
>>      },
>>      "config": {
>>          "optimize-autoloader": true
>>      }
>> }
>> ---------- END -------------
>>
>> (*) Note: when "optimize-autoloader" is set to false the error doesn't
>> occur.
>
> I think this may be to do with the 4096 error bug.
>
> Composer will pull in the files and run them. One of them is:
> vendor/propel/propel/src/Propel/Runtime/DataFetcher/PDODataFetcher.php
>
> From you project directory, try running:
> php vendor/propel/propel/src/Propel/Runtime/DataFetcher/PDODataFetcher.php
>
> That probably will give you a segfault. I'm not sure if changing the
> filesize will help, because composer probably will fetch a fresh copy of
> the file.
>
> I did provide a small patch a few weeks ago. That might help. You'd need
> to recompile and install php though cygports to use it.
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple