Web lists-archives.com

Re: Bash shell inside JPSOFT Take Command does not respond to input




On 2017-05-14 19:45, Jim Reisert AD1C wrote:
> I can't seem to get a bash shell to run inside of JP Software's Take
> Command:
>    www.jpsoft.com
> Behavior is the same in both TC and TCC - a shell starts, but I
> can't type anything into it.  This used to work in the recent past,
> so I don't know what changed, or when.  Both versions 20 and 21 of
> the JPSOFT product behave the same way:
> TCC  20.11.46 x64   Windows 10 [Version 6.3.16193]
> TCC Build 46   Windows 10 Build 16193
> Registered to JJR
> f:\>bash
> CYGWIN_NT-10.0 JJR 2.8.0(0.309/5/3) 2017-04-01 20:47 x86_64 Cygwin
> [JJR:/cygdrive/f] $  <<< at this point, nothing is echoed, nothing is
> accepted

Have you changed your {/etc/,~/.}profile, ~/.bash{_profile,rc}
recently?
Your output looks to be from uname -a, so something must be running it.
Try running bash from mintty and/or cmd and see what happens.
You could also try running bash -il --noprofile --norc.
If all else fails, try using dash, and test bash -nvx {/etc/,~/.}profile
and ~/.bash{_profile,rc}, then just -vx to see if something is borked.
Can you check the PATH set within bash?

Also may want to check recent changes in readline, in case they affect
how {/etc/,~/.}inputrc settings are used.

Do you have Ubuntu|Bash for Windows using the same home dir and could
that have replaced something used by tcc or bash?

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple