Web lists-archives.com

Re: cygpath compatiblity break (v2.1 -> v2.7)




On 10/05/2017 11:12, Chevallier Yves wrote:
Unfortunately I haven't tried 2.8 because we've already validated 2.7 internally and I would need at least 3 months to access to 2.8.

That said I searched for a release note with information about cygpath, but I haven't find any.


Bottom Post in this mailing list. Please.


Cygpath is part of the cygwin package.
The source specific of "cygpath" is unchanged by ~ 6 months. The issue you see was likely a change inside the cygwin dll.


About your internal validation, please note that the numbering scheme was changed with version 2.0

https://sourceware.org/ml/cygwin-announce/2015-04/msg00046.html

I suggest you to consider 2.x version as the successor of 1.7.x.

Regards
Marco





--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple