Web lists-archives.com

Re: setup release candidate - please test




On 08/05/2017 19:26, Peter A. Castro wrote:
On Mon, 8 May 2017, Jon Turney wrote:
[...]

- Add --allow-unsupported-windows option
Don't check the windows version.

Huzzah!!  Thanks for this!!

No problem.

The Cygwin mirror list is not read, so a URL (e.g. a Cygwin time
machine circa) should be given with --site or via the GUI.

- Remove support for some long-obsolete setup.ini syntax (omitted
version:, omitted size and checksum, various undocumented tokens)

Can you tell me what Setup will do if it encounters one of these
"obsolete" setup.ini?  Throw an error?  Ignore the omission (how?)?
Ignore the entire package entry??  Allow the user to continue anyway?

I'm afraid I'd have to test it to be sure, but I think that setup will report a syntax error and attempt to continue processing the setup.ini file.

I suspect the package will not be in very useful state lacking version or archive information.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple