Web lists-archives.com

camlp4o Fatal error: cannot load shared library dllunix




Hi,

I'm having issue with the camlp4 Cygwin package
(ocaml-camlp4-4.04+1-1) in the 64-bit Cygwin.
When I run camlp4o, it returns an error:

> $ camlp4o
> Fatal error: cannot load shared library dllunix
> Reason: flexdll error: cannot relocate RELOC_REL32, target is too far: 0xfffffffc0dad8b5f  0xdad8b5f

I tried rebaseall, but it didn't help.

I notice that ocaml-camlp4 depends on ocaml-base, which is "Obsoleted
by ocaml" according to
https://cygwin.com/cgi-bin2/package-grep.cgi?grep=ocaml-base&arch=x86_64
Could it be the source of error?

Interestingly, camlp4o works correctly in my 32-bit Cygwin, but not 64-bit one.

I wonder if anyone can reproduce the problem, or it's just my
machine's issue? Any help is appreciated.

Best regards,
Andy

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple